Will My Lightroom Version Work with your Presets?

Presets work in Lightroom Classic CC only. Unfortunately, Adobe doesn't allow presets to be used with the web-based Lightroom CC.

All of our presets require you to have Adobe Lightroom on your computer before you can use the presets. However you can purchase the presets if you'd like and import into Lightroom when you get it.

Our presets work best with Lightroom version 4 and newer.
Our photo collage templates work with all versions of Lightroom
Our "Polished" presets work with Lightroom 4 and newer however, please note the graduated filter "brush/erase" feature is only available with LR 6 or CC not older versions.

Still need help? Contact Us Contact Us